CVE-2026-111959

Updated on 02 Nov 2026

Severity

Awaiting Analysis

Details

Overview

About vulnerability

Out-of-bounds read vulnerability in Apache Arrow Rust (arrow crate), from version 33.0.0 through to versions 57.3.1, 58.4.0, 59.3.1 and 60.0.0.

Improper validation of RunEndEncoded arrays in the ArrayData interface can allow reading data beyond the bounds of the child values array.

Users are recommended to upgrade to versions 60.1.0, 59.3.2, 58.4.1, 57.3.2 which fixes the issue.

Details

Affected packages:
arrow @ 1.4.0 (+32 more)