Reminder to upgrade old KernelCare agent - TuxCare

Reminder to upgrade old KernelCare agent

KernelCare Team

November 9, 2020

KernelCare Update

KernelCareUpdate
If you are running kcarectl versions from 2.10-1 to 2.11-3, please upgrade to the latest version by running:

  • for rpm based servers – yum install -y kernelcare
  • for pkg based servers – apt-get install kernelcare
 These versions will no longer receive kernel patches due to their buggy mechanism of module inversion. The Bug causes a new module, delivered as a part of the latest patch-sets, being neglected and not loaded. The “old” module interpreted the new patch data in a wrong way, therefore the kernel might crash.
If your servers are still running these outdated agent versions – please update immediately.
Otherwise, you will start getting “Unknown Kernel” notification instead of new patches. From the moment the KernelCare agent (kcarectl) is upgraded, the patch delivery on your servers will be resumed.

Stay in the Loop

Resources

State of Enterprise Linux Cybersecurity ... Read More State of Enterprise Linux Cybersecurity ...
Dangerous remotely exploitable vulnerability ... Read More Dangerous remotely exploitable vulnerability ...
Securing confidential research data ... Read More Securing confidential research data ...
State of Enterprise Vulnerability Detection ... Read More State of Enterprise Vulnerability Detection ...
Demand for Rapid Risk Elimination for ... Read More Demand for Rapid Risk Elimination for ...
TuxCare Free Raspberry Pi Patching Read More TuxCare Free Raspberry Pi Patching